网站链接: element-ui dtcms
当前位置: 首页 > 技术博文  > 技术博文

Ubuntu16.04下安装uhd+gnuradio

2021/4/17 22:50:21 人评论

入坑gnuradio和uhd的安装和环境配置很久了,总结一下遇到的问题 thinkpad笔记本安装ubuntu16.04有问题,安装完就黑屏,试了很久各种方式都安装不上最后用了ubuntu18.04. Dell台式机(忘了是啥配置),两个版本都…

入坑gnuradio和uhd的安装和环境配置很久了,总结一下遇到的问题
thinkpad笔记本安装ubuntu16.04有问题,安装完就黑屏,试了很久各种方式都安装不上最后用了ubuntu18.04.
Dell台式机(忘了是啥配置),两个版本都能安装。

一共有三种方法配置环境
1、二进制码安装(方便,快速,无需配置环境,但是版本比较老)
2、源码安装(容易出现各种问题)
3、pybombs安装(大家都说好,但是我用着也不太方便)
以上均需先安装uhd,后安装gnuradio
1、二进制码安装
安装uhd
参考:https://launchpad.net/~ettusresearch/+archive/ubuntu/uhd

sudo apt-get update
sudo apt-get upgrade

安装依赖(仅限18.04版本,别的版本需要参考官方网站)

sudo apt-get -y install git swig cmake doxygen build-essential libboost-all-dev libtool libusb-1.0-0 libusb-1.0-0-dev libudev-dev libncurses5-dev libfftw3-bin libfftw3-dev libfftw3-doc libcppunit-1.14-0 libcppunit-dev libcppunit-doc ncurses-bin cpufrequtils python-numpy python-numpy-doc python-numpy-dbg python-scipy python-docutils qt4-bin-dbg qt4-default qt4-doc libqt4-dev libqt4-dev-bin python-qt4 python-qt4-dbg python-qt4-dev python-qt4-doc python-qt4-doc libqwt6abi1 libfftw3-bin libfftw3-dev libfftw3-doc ncurses-bin libncurses5 libncurses5-dev libncurses5-dbg libfontconfig1-dev libxrender-dev libpulse-dev swig g++ automake autoconf libtool python-dev libfftw3-dev libcppunit-dev libboost-all-dev libusb-dev libusb-1.0-0-dev fort77 libsdl1.2-dev python-wxgtk3.0 git libqt4-dev python-numpy ccache python-opengl libgsl-dev python-cheetah python-mako python-lxml doxygen qt4-default qt4-dev-tools libusb-1.0-0-dev libqwtplot3d-qt5-dev pyqt4-dev-tools python-qwt5-qt4 cmake git wget libxi-dev gtk2-engines-pixbuf r-base-dev python-tk liborc-0.4-0 liborc-0.4-dev libasound2-dev python-gtk2 libzmq3-dev libzmq5 python-requests python-sphinx libcomedi-dev python-zmq libqwt-dev libqwt6abi1 python-six libgps-dev libgps23 gpsd gpsd-clients python-gps python-setuptools

安装依赖后,重启系统

reboot the system

重启之后,安装uhd

sudo apt-get update
sudo apt-get install libuhd-dev libuhd003.010.003 uhd-host

Note:
(因为ubuntu里默认带uhd安装包,因此可以直接安装,默认版本是uhd3.10.3,如果想要安装新的版本的话,可以通过修改依赖源:
sudo add-apt-repository ppa:ettusresearch/uhd
sudo apt-get update
sudo apt-get install libuhd-dev libuhd003 uhd-host
但是不建议更改依赖源,因为会出现可能会出现两个版本的uhd,最终导致安装的uhd版本是3.15,但是gnuradio链接的是uhd3.10.3。因此直接默认使用ubuntu的uhd安装包。
详情参考https://blog.csdn.net/shikongjingliu/article/details/112185830)。

然后在命令行运行

uhd_find_devices

查看是否安装成功。

安装:gnuradio
参考:https://wiki.gnuradio.org/index.php/InstallingGR
.安装依赖
(有的已经在上面安装了)

sudo ap tinstall libcanberra-gtk-module

(不安这个,gnuradio-companion会报错,说缺少这个module)
2.安装

sudo add-apt-repository ppa:gnuradio/gnuradio-releases-3.7
sudo apt-get update
sudo apt install gnuradio

(针对linux18.04,额外需要的步骤)

cd /usr/share/gnuradio/modtool/gr-newmod
sudo py3clean .

3.测试安装成功

gnuradio-companion

另外两种方法下次更新。。。。

3、pybombs参考:
可能会因为网络问题无法下载安装包,需要挂到别的。。
安装uhd+gnuradio
参考:
https://mirrors.tuna.tsinghua.edu.cn/help/pybombs/
https://github.com/gnuradio/pybombs
https://sourceforge.isae.fr/projects/ralf/wiki/UHD_and_GNURadio_installation_from_sources_with_PyBombs
http://phwl.org/2020/installing-gnuradio-on-ubuntu/(我是按照这个安装)

先安装git、pip3、pybombs(不能用python2)

相关资讯

    暂无相关的数据...

共有条评论 网友评论

验证码: 看不清楚?